Saturday, September 28, 2013

Master Planning in Revit with Google Earth Image

We use sketchup a lot for conceptual design since it is fast and easy. Many designers in our office are so comfortable with the program. However, sketchup doesn't allow you to do any program area data and therefore, they often have to be manually done with excel or some other programs. It is time for a change.

We have a new project that is getting started in concept. We wanted to give it a shot and dive into Revit right from the start in programming. The team brought up a question and wonder if we can import a Google Earth image like we used to do in sketchup.

Google Earth image as background in sketchup
My immediate reaction was "Yes of course". I have played with an add-in from Revit in the previous version called "Acquire from Google Earth", you can import Google Earth image into Revit as well as publish Revit model to Google Earth. So I thought I would try it again in Revit 2014. The add-in tool is now updated called "Globe Link" (which can be downloaded from Autodesk subscription site); it does have the similar function like the early version in Revit.

After trying it again in Revit 2014, I ran into some error with the Google Earth. I found a blog post from the search that explained the compatibility issue between Revit and Google Earth and offered some resolution to fix that. I finally was able to get the site image imported to Revit. Nevertheless, the image only came in as a raster image that shows in plan view only. Not exactly what I want ...

I remember I did something similar in Vasari before. Vasari has a built-in function where you can bring in Google Earth image straight into Vasari and scale properly. It works seamlessly.

Why can't native Revit do this already!?
I thought I can save this as a .rvt file in Vasari then open it in Revit. I was happy for a moment and later realize it didn't quite work... Only an outline of the raster image showed up once the .rvt file opened in Revit.

Seems like this is another dead end to me. I thought there has to be a way to bring in just "an image" and use it in 3D view as backdrop. Then, a light bulb went off and it hit me. Why not use a decal?

A decal in Revit will show up everywhere including 3D view. Go to Insert tab --> Decal --> Place Decal
Make a new type, load the image and place it!

In order to place the image as a decal, I need a "host" or a surface to place it. I made generic model family with a solid extrusion to host this image. You can also use other elements like a floor to do so. As for the sizing of the decal, I had to use a trick to get it scale properly. I actually used the Vasari file that I made earlier, I drew some model lines at the boundary of the image, copy the model lines to the clipboard, and then paste them into my site file. Now that I had the actual size of the boundary, I could use the same image export from Vasari and placed it as a decal.

Once I had the decal scale properly, I could now see it floating in 3D view, the only drawback was I had to switch it to "realistic mode" in order to see the Google Earth image.

Make some simple in-place masses for the surrounding buildings and the site is good to go! This workaround was to replicate what we like to achieve in Sketchup. By going through this process, it doesn't offer what the add-in "Globe Link" can do, which is to publish the Revit model back into Google Earth.

Saturday, September 14, 2013

Old Meets New - Massing with Old School Array

I was working on something in the past 2 weeks on massing. I have used a trick of nesting traditional Generic Model family into massing (or adaptive component) and pick the lines to create form or surface on many occasions. This time around, I thought of another way of using Generic Model again for something new.

First, I started off with a Generic Model template and draw a spline as a model line, I have the spline constrained to the parameter "H". During the RTC NA this year, I learned something new from Marcello Sgambelluri about scaling with a spline.

Next, I nest this model line spline into another Generic model and array it.

In this family, I set up the "Scale" and "Array" as an instance parameter where I can use it to nest into a massing family.

Start another family as a mass, load the GM array family. Draw an ellipse (actually two open-ended arch to form an ellipse); and have the nested array family locked to the end point of the arch. Add parameters to constrain the ellipse "Radius_Depth" and "Radius_Width". At the same time, associate the parameter "Scale" and "Array" from the nested family to the mass.

 Next, select the spline array from both ends and the arch; then hit "Create Form"...


I have made a ribbed surface. To my surprise, the surface is now driven by the spline. When I flex the parameter "Array", it will flex along nicely...

 I went and made another surface on the opposite side and form a complete mass.

Load the mass family into the project and start messing with the instance parameters...

First one with Array = 12, and Scale = 10 & 20 respectively.

Second one with Array = 20, and Scale = 2 & 20 respectively.

 Third one with Array = 36, and Scale = 10 & 30 respectively.

 I could go on and make more masses but I was pretty happy with this result for now...

Ribbed towers using nested array old tricks
I am now in the process of using this method to create something which I will post for next week, so stay tuned!

Monday, September 9, 2013

Plan Region and View Range Bug in Floor Plan

I came across this weird behavior in Revit today and thought to write a quick post about it. I have this project in Revit 2014 and a number of the windows had a higher sill height on the wall.

By default, this window is not likely to show up on plan since the defaulted view range is set to cut at 4'-0" above finish floor.
So immediately I used "plan region" and set it on plan and thought that would fix it.

However, for some reasons, it didn't work no matter how I set the view range height within the "plan region" settings...
After going for the next 30 mins of trouble-shooting, I was able to figure out the issue and "fix" it. I had to locate my "plan region" completely away from the window and the wall in order for Revit to recognize it. As it may sound totally crazy and irrational to me, it somehow worked...

I still can't explain why this works since the plan region would work on a normal situation. I guess this is one of those weird behaviors that does it.

Thursday, September 5, 2013

ReCap Photo 3D Model Viewer Online

For those of you who read my last post about my ReCap Photo experience, I have included the online viewer link of the model so you can experience it yourself.

Keep in mind that you can only view this link with Chrome browser or browser that supports WebGL.

Click here to view